[Resolved]
[Resolved]

Home Forums Solveto – Multipurpose WordPress Theme Wrong classes, js errors, false outputs after updating theme

This topic is: not resolved

This topic contains 21 replies, has 2 voices, and was last updated by  innovationsraum 1 week, 2 days ago.


  • innovationsraum
    Participant
    Post count: 17
    | #14410

    Hello,

    we are a small web & design agency. Currently we’re helping a client with updating their WordPress website, which we didn’t make initially. This website uses your theme Solveto. Unfortunately we are not very familiar with the project and usually we don’t use premade themes. We bought the newest version of the theme, but while updating we encountered several errors or bugs.

    This is our maintenance server installation of the website:
    https://diagnostic.innovationsraum.de/

    Some things like the slider or missing fonts and navigation menus have to be setup again, but that’s our part, we can do that.

    These are the problems we couldn’t find a solution to so far:

    1. Tabs (and accordion)
    The content element of “Tabs”, which was used in the previous version, is deprecated (“Old Tabs”). We tried to replace it with the new tabs-element, but it seems that the output of the element isn’t quite right: Previously the tab elements got class names like tabbable tabs- or nav nav-tabs. But in the current version the class names are something like vc_tta-tab. This of course leads to a false display of styles.

    However, the element files in /solveto/vc_templates/ seem to be correct (as far as we know; correct class names etc.), but maybe they’re ignored or overwritten for some reason?

    2. FAQ
    On the front-page there’s an FAQ section at the right sidebar, displayed as an accordion. When clicking one of the items the following error occurs:
    Uncaught TypeError: Cannot read property 'getRelatedTab' of undefined at HTMLDocument.changeHandler (vc-tabs.min.js?ver=5.0.1:1)

    3. services_media
    The services_media element seems to have no output at all. Even the shortcode doesn’t get processed, but is just displayed as plain text.

    All these things are working as intended on your demo site. We also tried to activate the theme within a fresh new WordPress installation – the errors were still there. Well, I don't know if these errors are connected somehow, or if there’s a bigger problem with the theme or its installation.

    We really hope you can help us here.

    Thank you and greetings,
    Innovationsraum


  • Eldo
    Keymaster
    Post count: 6822
    | #14414

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14420
    This reply has been marked as private.

  • Eldo
    Keymaster
    Post count: 6822
    | #14425
    This reply has been marked as private.

  • innovationsraum
    Participant
    Post count: 17
    | #14429

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14444

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14451

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14452

    Replies only viewable for logged in users


  • Eldo
    Keymaster
    Post count: 6822
    | #14453

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14454

    Replies only viewable for logged in users


  • Eldo
    Keymaster
    Post count: 6822
    | #14455

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14456

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14457

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14458

    Replies only viewable for logged in users


  • Eldo
    Keymaster
    Post count: 6822
    | #14459

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14460

    Replies only viewable for logged in users


  • Eldo
    Keymaster
    Post count: 6822
    | #14462

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14463

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14464

    Replies only viewable for logged in users


  • Eldo
    Keymaster
    Post count: 6822
    | #14471

    Replies only viewable for logged in users


  • Eldo
    Keymaster
    Post count: 6822
    | #14475

    Replies only viewable for logged in users


  • innovationsraum
    Participant
    Post count: 17
    | #14482

    Replies only viewable for logged in users

You must be logged in to reply to this topic.